• Welcome to Ranger6G.com everyone!

    If you're joining us from Ranger5G, then you may already have an account here! As long as you were registered on Ranger5G as of March 27, 2020 or earlier, then you can simply login here with the same username and password.

Just bought 2020 Ford Ranger, already has Powertrain Malfunction/Reduced Power Notice

jkc1362

New Member
First Name
Janice
Joined
Aug 13, 2020
Messages
2
Reaction score
1
Location
Burien, WA
Vehicle(s)
2020 Ford Ranger Lariat
Hi, I'm brand new to this forum. As a birthday gift to myself (I turned 50), I bought a brand new 2020 Ford Ranger Lariat on Monday Aug 10. While test driving the truck, the orange wrench icon came on. They had a tech look at it and said it was a sensor that isn't safety related and to make an appointment to bring it in. So I did (long story short, the Sales Manager got it in sooner for me). Also, the notice popped up on myford pass app and it said Powertrain Malfunction/Reduced Power and states system has detected a powertrain or four wheel drive fault. I dropped the truck off last night and today they called today saying that the fault code that showed up on their end is something they haven't seen before and has escalated this to a Regional Tech (someone more experienced) to see what the deal is. They said it will be about 24-48 hours before they get a response from this regional tech. Truck drives fine but I wanted this fixed asap as I'm going on a short road trip end of next week. Is this something that has happened to anyone here?
 

EcoRanger

Well-Known Member
First Name
Doc
Joined
Aug 20, 2018
Messages
782
Reaction score
330
Location
West By God Virginia
Vehicle(s)
2019 Ranger XLT 301A SuperCrew 4X4 2015 Ecoboost Mustang 50 Year Appereance Package convertible
Vehicle Showcase
5
Sorry to hear you've had a problem my 2019 Ranger has over 20k and has been as smooth as hot butter.
 
OP

jkc1362

New Member
First Name
Janice
Joined
Aug 13, 2020
Messages
2
Reaction score
1
Location
Burien, WA
Vehicle(s)
2020 Ford Ranger Lariat
  • Thread starter
  • Thread Starter
  • #3
Sorry to hear you've had a problem my 2019 Ranger has over 20k and has been as smooth as hot butter.
well funny thing, after 8 days in the shop, they found the issue. IT was a connector from a wiring harness underneath the driver's side panel that wasn't connected all the way. UGH! So it's all fixed and she purrs like a kitten now!. I'm loving my new truck!
 
Top